R语言系列:编译安装R的一些问题

1、error: No F77 compiler found 
安装gfortran 
2、error: –with-readline=yes (default) and headers/libs are not available 
安装libreadline6-dev 
3、error: –with-x=yes (default) and X11 headers/libs are not available 
安装libxt-dev 
4、error: C++ preprocessor "/lib/cpp" fails sanity check 
安装g++或build-essential

参考资料:
http://blog.csdn.net/chenyi8888/article/details/8065318

附:
安装R-2.15.2后,再安装rStudio,出现错误。
1、提示找不到libR.so,并建议增加'--enable-R-shlib'。根据提示使用
./configure --enable-R-shlib
2、设置完成后再编译出现共享库生成错误,提示使用'fPIC'。
经几番尝试,未解决此问题。
所以建议不要轻易编译安装R。而且在使用'fPIC'后编译过程变长。
可能正确的命令:
./configure --enable-R-shlib CFLAGS=-fPIC FCFLAGS=-fPIC
不正确的命令:
./configure --enable-R-shlib CPICFLAGS=-fPIC

最后:
若要删除,请执行
    ./configure

    sudo make uninstall


原文: https://my.oschina.net/explore/blog/101861

收藏 0 0

共0条 1

登录 后发表评论。没有帐号? 注册 一个。